DoH with Firefox

Forums Networking, Routing, Technology DoH with Firefox

  • October 26, 2019 at 3:50 am

    Has anyone been able to get DoH to work with Firefox?  Firefox now supports it but it doesn’t seem to work with CleanBrowsing: https://doh.cleanbrowsing.org/doh/family-filter/.  I have tested it with others such as AdGuards: https://dns-family.adguard.com/dns-query and am able to get it to work. Wondering if there is a known issue.  Also is it possible to get the fallback or bootstrap IP for the DoH with CleanBrowsing?  Firefox has three settings that can be set along with a ttr mode setting as to if it will require DoH always or not.

    network.trr.uri;https://dns-family.adguard.com/dns-query

    network.trr.custom_uri;https://dns-family.adguard.com/dns-query

    network.trr.bootstrapAddress;

    October 26, 2019 at 7:03 am

    I have it working here without any issues.

    I set the bootstrap address to 185.228.168.10.

    We recommend the trr mode to be set to 2 or 3 if enabled.

    thanks!

    October 28, 2019 at 7:33 pm

    I have it working now with both the bootstrap IP above entered above and trr mode set to 3.  Appreciate it!

    October 29, 2019 at 4:25 pm

    Awesome! Let us know if we can help with anything else.

    January 20, 2020 at 2:53 pm

    I saw a posting in the “News” forum that one will not be able to override the CleanBrowing filter in Firefox’s DoH settings. My understanding is that Chrome now provides a similar experimental DoH capability. Will the Chrome setting override the CleanBrowsing filter?

    January 21, 2020 at 9:12 pm

    Nope, we are working with the Chrome team and they will honor your CleanBrowsing settings.

     

    thanks!

    February 11, 2020 at 6:15 pm

    Hi,
    I tried to use the “Family Filter”
    with DNS: 185.228.168.168
    but it did not block any content when accessed through VPN app.
    What might be the reason for this?

    February 26, 2020 at 2:58 am

    we are working with the Chrome team and they will honor your CleanBrowsing settings

    Daniel, I also saw the similar statement about Firefox in the news section. Can you please elaborate on how this is supposed to work?

    I just did a quick test with FF 73.0.1 on Windows. The adult filter is setup in my router as the default dns, and filtering was working correctly. Then I enabled DoH in FF settings, closed FF, flushed dns cache, restarted FF, and observed that cleanbrowsing is bypassed. 🙁

    This seems like a big problem now that Firefox is going to start enabling DoH by default. Any suggestions on deal with it at the router level?

    Thanks

    February 27, 2020 at 4:52 am

    Hello,

    I cannot get DoH to work with Firefox using the free security  CleanBrowsing IP Address.  I tested it with Cloudflare ESNI

    https://www.cloudflare.com/ssl/encrypted-sni/

    I also changed IPv4 and v6 addresses in my router to CleanBrowsing IP addresses and checked with dns leak which shows no leak and correct Clean Browsing connection. Does DoH work with Security filters only?

    These are my settings:

    network.trr.uri;  <i>https://doh.cleanbrowsing.org/doh/security-filter/</i&gt;

    network.trr.custom_uri; <i>https://doh.cleanbrowsing.org/doh/security-filter/</i&gt;

    network.trr.bootstrapAddress; <i>185.228.168.9</i>

     

    February 27, 2020 at 4:52 am

    I have it also configured CleanBrowsing in a router and am using FF 73.0.1.  These setting are working for me behind the router and also at other locations I don’t control DNS which is part of the point of using doh.  The below must be configured through about:config in the address bar versus about:preferences > Network  > Settings.

    network.trr.bootstrapAddress:    185.228.168.10
    network.trr.custom_uri:    https://doh.cleanbrowsing.org/doh/family-filter/
    network.trr.mode:    3
    network.trr.uri:    https://doh.cleanbrowsing.org/doh/family-filter/

     

    February 27, 2020 at 4:53 am

    I have it working with doh enabled in Firefox both behind a router setup with CleanBrowsing DNS and other locations where I can’t control DNS.  I am using FireFox 73.0.1 also.

    The below settings are working.  You must configure this via about:config in the address bar vs preferences > network > setttings:

    network.trr.bootstrapAddress:    185.228.168.10
    network.trr.custom_uri:    https://doh.cleanbrowsing.org/doh/family-filter/
    network.trr.mode:    3
    network.trr.uri:    https://doh.cleanbrowsing.org/doh/family-filter/

    February 27, 2020 at 5:02 pm

    seefore,

    Apologies if I’m wrong, but

    Isn’t your bootstrap address for the adult filter (shouldn’t it be 185.228.168.168 for the family filter?)

    or (if you are aiming to use the adult filter) shouldn’t your uris be https://doh.cleanbrowsing.org/doh/adult-filter/ ?

    March 24, 2020 at 3:55 pm

    So it doesn’t work by just adding the Clean Browsing domain into the custom field in Firefox?
    Edit: by adding this one https://doh.cleanbrowsing.org/doh/family-filter/

    • This reply was modified 2 weeks, 2 days ago by Peter.
    • This reply was modified 2 weeks, 2 days ago by Peter.
    April 8, 2020 at 6:30 pm

    Simon, looks like I posted twice but yes you are correct and my error.  Last time I tested I could not get it to work unless trr mode is 3 ie no failback mode also.

    FAMILY FILTER

    network.trr.bootstrapAddress:    185.228.168.168
    network.trr.custom_uri:    https://doh.cleanbrowsing.org/doh/family-filter/
    network.trr.mode:    3
    network.trr.uri:    https://doh.cleanbrowsing.org/doh/family-filter/

    ADULT FILTER

    network.trr.bootstrapAddress:    185.228.168.10
    network.trr.custom_uri:    https://doh.cleanbrowsing.org/doh/adult-filter/
    network.trr.mode:    3
    network.trr.uri:    https://doh.cleanbrowsing.org/doh/adult-filter/

    per:

    https://cleanbrowsing.org/ip-address

    https://cleanbrowsing.org/guides/dnsoverhttps

    April 8, 2020 at 6:48 pm

    Custom DNS

    So it doesn’t work by adding the Clean Browsing domain (“https://doh.cleanbrowsing.org/doh/family-filter/&#8221;) in the custom field?