DNS will not work with Comcast

Forums Service Issues Networking, Routing, Technology DNS will not work with Comcast

  • March 5, 2020 at 5:32 am

    I currently have Comcast as my ISP. I am trying to run clean browsing for my DNS. I have the IP’s set on my modem. I do not rent one of their modems, so I am unable to go in to the settings and turn off protected mode. When I run a dns leak test, 2 of my devices have the cleanbrowsing, while my other devices have Comcast for DNS. I have tested many times and have even wiped a device and brought it back and it is still getting Comcast as the DNS. What are my options? Is this something that Comcast has locked down and I can not change my DNS unless I have one of their modems.

    March 5, 2020 at 3:36 pm

    One option would be to use our Apps on every device. Our Windows App, for example, forces DoH and will overwrite Comcast’s DNS. Would that work?

    thanks,

    March 5, 2020 at 4:00 pm

    Daniel, thanks for the reply. This could work for some of my devices in the house, as most of us have iphones. However, we also have several kids with Kindles and there is no App for that device. We also want to be able to protect any device that comes into our home and joins our network.

    In doing some more research last night, I think that I might have found my problem to be my modem. I have a Netgear 6900. I have set the DNS for clean browsing, however, on my Kindle which does not work, when I do a look at my IP I am pulling down, it is pulling down an IPV6 IP for DNS, which is defaulting to what is provided by the ISP. I am unable to turn this off. The modem does allow me to enable Parental Controls but it only works with OpenDNS. This does not solve my issue as OpenDNS does not do safe search. Have you seen this before? Maybe if I could get IPV6 turned off it might work, but so far no luck. I am going to keep doing some research on this model, the Netgear 6900. Thanks,

    March 10, 2020 at 4:32 am

    Quick question, if you go here:

    https://internet.xfinity.com/network/protected-browsing

    Can you disable protected browsing for your account? It runs on their side and not on your router.

    thanks!

    March 10, 2020 at 5:20 am

    Daniel, if i follow that link and sign in to my account, I receive this notification¬† – Upgrade for This Experience. To access xFi, you’ll need to upgrade your service/equipment. Learn more about eligibility requirements. While I did not toggle this off while I had one of their modems, I am thinking they disabled this automatically when i switched off renting their modems. In doing more research, I fully believe the issue is now with my modem itself. I purchased a Netgear AC1900 Cable Modem. Model # C6900. It is pre configured to work with OpenDNS. There is an option to click on the parental control inside this interface and it opens an OpenDNS sign in page. Once I signed up for a free account and set OpenDNS to monitor my internet, none of my devices have an issue now. When I run dns leak test, they all show as using OpenDNS. I did not do enough research to know that this was hardwired into the modem. I found a Netgear article out there where someone posted the same issue. He said to configure Open DNS and there was really not away around it. I do not know if all Netgear Models are configured this way, but this one is. I will need to look into a circle plus to set some cleanbrowsing controls. If I find that article again I will post it here. If there are other suggestions I am up for it. Thanks,

Tagged: