I have some problem with CleanBrowsing Adult Filter

Forums Service Issues Networking, Routing, Technology I have some problem with CleanBrowsing Adult Filter

  • November 16, 2020 at 9:35 pm

    I have been testing Cleanbrowsing for some weeks and this evening bad results started to show up while searching on http://www.bing.com. Changing to CloudFlare has no issues here. I think it some strange network issues at hand here.

    I use dnsmasq to forward my network queries to external dns service like CleanBrowsing Adult filter:

    IPv4 address: and

    Exampel: when I surf to http://www.bing.com and search for the word “sex” I get unwanted results. That has never happened before. So there is probably some network issues going on here because sometimes it works, sometimes it don’t.

    I hope it’s not the iOS 14 on my iPhone that is using some strange DoH.

    November 16, 2020 at 10:04 pm

    I have done some testing and it seems to by iOS version 14 that giving the mixed results. Firefox on laptop and older iPads have no issue here. Sorry for my shout-out. I will do some further testing here..

    November 16, 2020 at 11:34 pm

    Well, after more testing at home it seams clearly there is something going on with Safari on the latest OS 14.

    Safe search bugg with bing.com:

    1. Surf to bing in Safari and search for an adult word.
    2. Hit the ”Home button” so that Safari is suspended.
    3. Wait some seconds
    4. Bring up Safari again and hit refresh.
    5. You should now see adult search results?

    Could someone verify or debunk this?

    November 18, 2020 at 9:09 pm


    Thanks for taking the time to test this. What’s really weird is why would it only happen with Bing, but not Google.

    Are you not experiencing the same issue with bing on other browsers like Chrome or Firefox on that mobile device?

    What happens when you reboot and clear the browser cache?


    November 19, 2020 at 12:54 am


    Thanks for the reply.

    To answer your question: Yes, I have tried it on Firefox on my iPhone with same result. Even after reboot/cache cleared. So it’s probably something to do with the iOS 14 web engine.

    How does iOS 14 Safari receive the correct unrestricted search?

    Nevertheless, the links are not clickable.


    November 22, 2020 at 10:56 am

    Hi again!

    Just want to add that it’s seems confirmed that this is a problem and unresolved issue with iOS 14.

    Excerpt from the apple forum on this subject (not my comment):

    “ No I suspect you’re right. For an even simpler example, Safe Search isn’t even enforced on the in app browsers anymore.

    For instance:

    1) Open the Notes app
    2) Type http://www.google.com
    3) Click on this to open an in app browser
    4) Type “sex” in images. By default in fact Safe Search is off when doing this.

    This works on literally any in app browsing screen. 14.2 has not resolved this”

    Link to discussion: https://discussions.apple.com/thread/252055463

    Apple has to fix this. It’s not acceptable!