Changing DNS on Kindle Fire

Forums Setups & Configurations Changing DNS on Kindle Fire

  • March 9, 2020 at 3:08 am

    I followed the step by step directions to change the DNS on my Kindle Fire.  Entered the numbers provided under DNS1 and DNS2.  However, once I was finished, the Kindle would not let me hit “Save”. That button was grayed-out.  How do I get it to save?

    March 10, 2020 at 4:30 am

    Mind taking a screenshot so we can see what is going on?

    March 21, 2020 at 2:49 am

    I had the same problem. I had to change my IP address to 192.168.1.20

    April 9, 2020 at 1:04 pm

    I had the same problem. I needed to manually add the IP addresses in (they were greyed out) to the ghosted values before it let me hit save. That seemed to work, but then I found a ton of websites that wouldn’t resolve – even basic ones like duckduckgo.com and sony.com. I also couldn’t even reach the Amazon app store. I’m not sure if the connections were temporarily or permanently unavailable, but I’ve since reset things back to the way they were. 🙁 Just not working correctly.

    Just tried changing the first IP address to .20, but the problem is still there. Exact message from the Silk browser when trying to go to sony.com:

    The site can’t be reached
    http://sony.com/ is unreachable.

    Also tried going to cnn.com , msnbc.com and foxnews.com. CNN worked, the others did not.

    • This reply was modified 10 hours, 54 minutes ago by nhanimator.
    April 9, 2020 at 1:13 pm

    Note: Power-cycling the Kindle made no difference.

    Simple changing the setting back to DHCP, without a power-cycle, restored all sites.

Tagged: