Allowing specific host

Forums Service Issues Setups & Configurations Allowing specific host

  • June 1, 2020 at 7:20 am


    I downloaded the cleanbrowsing setup and activated the adult filter.

    It works great so far, but it blocks a scientific tool I use, RStudio.

    After some troubleshooting I found out that this is my problem:

    Although RStudio does not require internet access, it does use a localhost connection to link your R session with the RStudio IDE. As a result, it is possible a (software-based) firewall, network setting, or antimalware program is blocking access to RStudio. If you have a firewall, HTTP or HTTPS proxy configured, add localhost and to the list of approved Hosts and Domains. After this, try restarting RStudio. If you have antimalware software configured that may be blocking RStudio, please check its settings and whitelist RStudio if necessary.

    Can I allow the access to this domain with the free version of clean browsing?

    June 2, 2020 at 2:07 am

    Oh yes, if you go to your /etc/hosts file you can make sure that localhost is mapped to and it won’t go through our DNS. The computer will check that file first before doing the DNS lookup.


    June 2, 2020 at 6:24 am